Fluent Help Center

    Car Connect FAQ


    Vehicle Compatibility

    Works with vehicles with an OBD-II port (standard on vehicles manufactured in 1996 or later. Hybrid and electric vehicles are not currently supported.
     

    Not showing in Fluent App

    1. Ensure device is fully plugged in

    2. Contact Fluent to ensure device has been added correctly on your account

    3. Verify LED


     




    Did this help resolve your question?

    Send feedback

    Can’t find what you’re looking for?

    Our award-winning customer care team is here for you.

    Contact Support
    Fluent's Blog Fluent on Facebook Fluent on Twitter